Azure Cloud Services Issues

Incident Report for Seismic Software, Inc.

Resolved

Azure closed out its incident and full recovery was observed at approximately 4:20 PM PDT. Seismic observed loading issues with the Outlook Add-in during the incident. Details about the incident can be located here. https://azure.status.microsoft/en-us/status/history/
Posted Oct 29, 2025 - 21:39 PDT

Update

Issues have bee isolated to Azure, no impact to AWS. Azure is currently assessing failover options. At this time Seismic is seeing impact to the Outlook Add-In. They will continue to provide Seismic updates.
Posted Oct 29, 2025 - 10:12 PDT

Identified

We are seeing issues loading the Outlook Add-In due to service issues in Azure Cloud Services. The team is continuing to investigate and in communication with Azure.
Posted Oct 29, 2025 - 09:41 PDT

Investigating

Seismic is seeing issues with services in Microsoft Azure Cloud and AWS services. Any impact to Seismic is being investigated. At this time all regions appear operational.
Posted Oct 29, 2025 - 09:26 PDT
This incident affected: U.S. West0, U.S. West1, U.S. West2, U.S. West3, U.S. East0, U.S. East1, U.S. East2, U.S. East3, U.S. East4, U.S. SouthWest1, Office Online, and Outlook Add-In.