Some customers experiencing 404 errors navigating in the platform

Incident Report for Seismic Software, Inc.

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 10, 2026 - 10:31 PDT

Update

We are continuing to investigate this issue.
Posted Jul 10, 2026 - 09:45 PDT

Investigating

We are currently investigating this issue.
Posted Jul 10, 2026 - 09:38 PDT
This incident affects: U.S. West0, U.S. West1, U.S. West2, and U.S. West3.