Livesend and DSR Issues

Incident Report for Seismic Software, Inc.

Resolved

This incident has been resolved.
Posted May 15, 2025 - 16:28 PDT

Update

We are continuing to monitor for any further issues.
Posted May 15, 2025 - 13:38 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 15, 2025 - 13:37 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 15, 2025 - 13:26 PDT

Investigating

Some customers in the West U.S. regions are unable to send emails, or create and view LiveSend links and DSRs. Our teams are currently investigating the issue.
Posted May 15, 2025 - 12:52 PDT
This incident affected: Digital Sales Room and LiveSend.