Seismic is experiencing intermittent issues due to AWS service disruptions

Incident Report for Seismic Software, Inc.

Resolved

Amazon AWS has provided a final update on today incident. https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 17:04 PDT

Monitoring

We are seeing recovery from the Amazon AWS outages reported today. We are continuing to monitor all Seismic services running on the Amazon AWS cloud.
Posted Oct 20, 2025 - 14:24 PDT

Update

We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 10:12 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 20, 2025 - 09:43 PDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 09:35 PDT

Investigating

We are currently investigating this issue.
Posted Oct 20, 2025 - 09:28 PDT
This incident affected: Digital Sales Room, Email Blast, FTP Service, Learning Web, LiveInsights, and LiveSend.