Customers in CH1 (Switzerland) region experiencing issues with tenant availability due to Azure Storage problem

Incident Report for Seismic Software, Inc.

Resolved

Azure fully resolved the incident and all Seismic services were recovered. We will continue to monitor closely and initiate failover plans if needed.
Posted Sep 28, 2025 - 11:56 PDT

Monitoring

Microsoft Azure has restored service in the Switzerland region.
Posted Sep 26, 2025 - 22:49 PDT

Update

Microsoft Azure has identified an issue in their Switzerland North region and is currently working on next steps.
Posted Sep 26, 2025 - 19:38 PDT

Update

We are continuing to work on a fix for this issue.
Posted Sep 26, 2025 - 19:04 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 26, 2025 - 18:07 PDT
This incident affected: CH1 (Switzerland).