Scheduled Maintenance for Seismic Infrastructure Upgrades - Profile Builder

Scheduled for Dec 5, 21:00 PST  -  Dec 6, 05:00 PST

Update

We will be undergoing scheduled maintenance during this time.
Posted Nov 21, 2025 - 09:43 PST

Update

We will be undergoing scheduled maintenance during this time.
Posted Nov 14, 2025 - 10:56 PST

Scheduled

Seismic will be performing infrastructure upgrades during this window.

Seismic Regions Impacted: CH1

Impact:
* Profile Builder page will be intermittently unavailable.
* Notification Center will be intermittently unavailable.
* All Notifications will not be sent out

We apologize for any inconvenience this may cause.
Posted Nov 14, 2025 - 05:42 PST
This scheduled maintenance affects: CH1 (Switzerland).