Intermittent Video Playback Issues

Incident Report for Seismic Software, Inc.

Resolved

A fix has been implemented and we are monitoring the results.
Posted May 14, 2025 - 15:20 PDT

Identified

Seismic’s third-party video vendor is experiencing intermittent playback issues, which may impact video performance. We’re monitoring their progress and will share updates as available.
Posted May 14, 2025 - 14:54 PDT
This incident affected: Content Video and Learning Video.