Seismic is currently experiencing service impacts due to a third-party vendor incident affecting AWS infrastructure in the US-East-1 region.

Incident Report for Seismic Software, Inc.

Resolved

We are starting to see recovery of infrastructure in AWS’ US-East-1 region, and will continue to monitor the recovery progress.
We will continue to provide updates as they become available.
Posted Oct 20, 2025 - 03:08 PDT

Investigating

We are currently experiencing limited service impacts due to a third-party vendor incident affecting AWS infrastructure in the us-east-1 region.

We are actively monitoring the situation and will provide updates as the vendor works toward resolution.
Posted Oct 20, 2025 - 02:55 PDT
This incident affected: U.S. East1.