We are continuing to work on a fix for this issue.
Posted Jul 23, 2026 - 09:10 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 23, 2026 - 09:02 PDT
Update
Azure acknowledged connectivity issues with their WestUS region. Our teams have re-routed some traffic from US West to East regions to mitigate impact.
Posted Jul 23, 2026 - 09:00 PDT
Update
Seismic has re-routed some traffic to other regions to mitigate impact and continues to be in contact with Microsoft support on resolution of this incident.
Posted Jul 23, 2026 - 08:49 PDT
Identified
Microsoft Azure is experiencing issues in US regions. Our teams are working on mitigation efforts and in contact with Microsoft.
Posted Jul 23, 2026 - 08:32 PDT
Update
We are continuing to investigate this issue.
Posted Jul 23, 2026 - 08:26 PDT
Update
Additional regions have been added as being impacted in US East regions. Seismic engineering is investigating possible root cause at Microsoft Azure services.
Posted Jul 23, 2026 - 08:14 PDT
Investigating
We are currently investigating this issue.
Posted Jul 23, 2026 - 08:02 PDT
This incident affects: U.S. West0, U.S. West1, U.S. West2, U.S. East0, U.S. East4, LiveInsights, and Service Platform.