Issue with vimeo player

Incident Report for Seismic Software, Inc.

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 10:57 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 01, 2025 - 08:41 PDT

Update

We are continuing to work on a fix for this issue.
Posted Apr 01, 2025 - 07:38 PDT

Identified

Some customers might experience issue loading videos, this is caused by an outage on vimeo side.
Seismic team is monitoring.
Posted Apr 01, 2025 - 07:17 PDT
This incident affected: Learning Video, Learning Web, and Mobile App.