Support Ticketing Portal and Chat Support Undergoing Maintenance

Incident Report for Seismic Software, Inc.

Resolved

All support services are back in operation and functioning at this time.
Posted Oct 27, 2025 - 08:02 PDT

Update

The support ticketing portal at support.seismic.com is available at this time. Chat Support is still currently under maintenance. Please open a support case via the portal or by emailing support@seismic.com if Support is needed.
Posted Oct 26, 2025 - 23:07 PDT

Update

We are continuing to work on a fix for this issue.
Posted Oct 26, 2025 - 17:08 PDT

Identified

The support ticketing portal and chat support in tenant are currently undergoing maintenance. Customers can use support@seismic.com for opening support tickets until the maintenance is completed.
Posted Oct 26, 2025 - 10:07 PDT
This incident affected: Chat Support and Inbound Customer Support.