Login issues for some Seismic customers in East US Region

Incident Report for Seismic Software, Inc.

Update

Seismic engineering has confirmed that the impacted service has fully recovered and all EAST0 tenants were back online as of approximately 3:30 PM ET.

We sincerely apologize for the disruption this caused to your teams today. We understand the impact this had on your business and are committed to ensuring the reliability of our platform. A full post-mortem is being conducted at this time.

Thank you for your patience and understanding.
Posted Jun 02, 2026 - 14:15 PDT

Monitoring

Seismic engineering is seeing signs of stability, with the impacted services returning to a healthy state. We are continuing to monitor the environment closely to ensure full recovery. Root cause investigation remains active to understand what caused the initial degradation and prevent future occurrences.

We will continue to provide updates as we have them.
Posted Jun 02, 2026 - 13:27 PDT

Update

Seismic engineering has continued to scale out the impacted service further, and we are starting to see signs of recovery. The root cause of the degradation is still being determined, and we are still investigating.

Seismic engineering is continuing to ensure stability with additional follow-up actions, including pulling additional diagnostics into the impacted service to understand what caused the initial degradation.

We will continue to provide updates as we have them.
Posted Jun 02, 2026 - 12:33 PDT

Update

The engineering team is continuing to resolve tenant accessibility issues in the EAST0 region.

We initiated a rollback of the impacted service, but that did not fully alleviate stability issues for the Seismic platform in the region. We are continuing to move forward with pulling additional diagnostics to determine the source of the instability.

We will continue to provide additional updates.
Posted Jun 02, 2026 - 12:02 PDT

Update

The Seismic Engineering Team is continuing to work on resolving tenant accessibility in the EAST0 region. We'll provide additional updates as we have them.
Posted Jun 02, 2026 - 11:30 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 02, 2026 - 10:52 PDT

Investigating

We are currently investigating this issue.
Posted Jun 02, 2026 - 09:49 PDT
This incident affects: U.S. East0.