Some customers are experiencing "the video does not exist" or other errors when attempting to watch videos

Incident Report for Seismic Software, Inc.

Resolved

This incident has been resolved.
Posted Apr 14, 2026 - 15:02 PDT

Monitoring

Vimeo has recovered and we continue to monitor.
Posted Apr 14, 2026 - 11:06 PDT

Update

Vimeo has identified the issue and is implementing a fix.
Posted Apr 14, 2026 - 10:13 PDT

Identified

Some videos beginning to recover through Seismic's backup measures. We continue to communicate with Vimeo on full recovery.
Posted Apr 14, 2026 - 10:07 PDT

Update

Vimeo, Seismic's video provider, is currently experiencing issues on their platform. Seismic is engaging with Vimeo to identify cause and resolution. https://status.vhx.tv/
Posted Apr 14, 2026 - 09:51 PDT

Investigating

We are currently investigating this issue.
Posted Apr 14, 2026 - 09:50 PDT
This incident affected: Content Video.