Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 21, 2025 - 16:01 PDT
Scheduled
Seismic is performing backend changes during this maintenance window and the following will be impacted for customers in our East0, East2, and East3 regions:
Emails: Emails will still be sent, but they will appear as not sent until maintenance complete
LiveSend session summaries: LiveSends will still be viewable, but the views would not reflect in engagement center until maintenance complete
SendGrid tracking events: Events such as Delivered, Bounced, etc would not reflect in engagement center until maintenance complete
LiveSend link clicks in engagement center: Links would appear in engagement center as unclicked until maintenance complete
We apologize for any inconvenience this may cause.
Posted Mar 17, 2025 - 11:55 PDT
This scheduled maintenance affected: U.S. East0, U.S. East2, U.S. East3, Email Blast, and LiveSend.