Scheduled Maintenance for Seismic Infrastructure Upgrades

Scheduled for Sep 19, 21:00 PDT  -  Sep 20, 05:00 PDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Sep 04, 2025 - 10:12 PDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Sep 04, 2025 - 08:15 PDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Sep 04, 2025 - 08:14 PDT

Scheduled

Seismic will be performing infrastructure upgrades (on our East0, East2, and East3 regions).

The following services will have intermittent availability during the maintenance window:

Webhook Events:
• Webhook notifications will not be delivered during downtime; they'll be sent once service resumes.
• Customers will not be able to create new webhook triggers in Power Automate.

App Management:
• Customers will not be able to install, enable, disable, or delete apps during this time.
• App extension features (like Main Nav, Search, Related Training, Delivery Approvals) will be unavailable.
• Slack and Teams notifications from apps will not be delivered.
• App installation status won't appear on Seismic Exchange.

Authorization: Access to shared content via DSR will be unavailable.

Seismic for Slides & Presentation Builder: Customers will not get update notifications and source presentations will not function.

Guided Assembly: Guided Assembly in Presentation Builder will be unavailable.

Self-Service Reports: Self-service reports will be unavailable during the maintenance window.

We apologize for any inconvenience this may cause.
Posted Aug 28, 2025 - 10:35 PDT
This scheduled maintenance affects: U.S. East0, U.S. East2, and U.S. East3.