Google Cloud outage affecting Seismic's video services

Incident Report for Seismic Software, Inc.

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 15:09 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 12, 2025 - 14:20 PDT

Identified

Google Cloud (GSP) is currently experiencing an outage which is affecting Vimeo's video services with Seismic. They have reported the issue is being mitigated and locations are recovering at this time. Customers may see issues with video uploads and playback. More details can be found here - https://status.cloud.google.com/index.html
Posted Jun 12, 2025 - 12:36 PDT
This incident affected: Content Video and Learning Video.