Some Livesend customers in EAST U.S. regions experiencing errors and failures

Incident Report for Seismic Software, Inc.

Resolved

This incident has been resolved.
Posted Dec 23, 2025 - 07:59 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 22, 2025 - 13:24 PST

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 22, 2025 - 13:17 PST

Investigating

Some customers may experience Livesend delays or errors when using Salesloft, Outreach, or link swap. Teams are currently investigating.
Posted Dec 22, 2025 - 11:37 PST
This incident affected: LiveSend.