Login Issues for Switzerland Customers

Incident Report for Seismic Software, Inc.

Resolved

This incident has been resolved.
Posted Feb 26, 2026 - 21:47 PST

Investigating

We are currently investigating this issue.
Posted Feb 26, 2026 - 21:30 PST
This incident affected: CH1 (Switzerland).